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How to create an animated face 
This activity walks you step by step through the process of creating a simple animation by using Adobe Flash CS4. 
You use drawing tools and implement motion and shape tweens. After you test your movie, you publish it for 
playback by others, either through a browser or directly with Flash Player. 


Draw facial features 


Draw the right eye 


1. Start Flash and open a blank new document. 


2. The new document contains one layer and one empty 
keyframe. 


3. Select the Oval tool and draw a small circle to represent 
the right eye on a face (Figure 1). 


4. Select the Selection tool and double-click the circle’s 
center to select it. You should see both its outline 
(stroke) and center (fill) selected. 


5. To change the outline color of the eye, click the Stroke 
Color box in the Property inspector and select a new 
color (Figure 2). To change the fill color, use the Fill 
Color box. 


6. On the Timeline, double-click the layer name, Layer 1 
(Figure 3). 


 This selects the layer name so you can rename it. 


 
Figure 1 Right eye drawn with Oval tool 


 


 
Figure 2 Image Property inspector 


 


 
Figure 3 Layer name 
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Fill color 
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7. Rename the layer Right Eye and press Enter (Windows) 
or Return (Mac OS) (Figure 4). 


 
Figure 4 New layer name 


Save the eye graphic as a symbol in the library 


Instead of creating two eyes separately, convert the right eye from a shape to a graphic symbol. This adds the eye to 
the library so you can use it over and over. This will also reduce the size of your finished movie. 


 


8. On the Right Eye layer, click frame 1 to select it 
(Figure 5). 


 This automatically selects the contents of frame 1. 


 Note: If the right eye is not completely selected, double-
click the eye on the Stage with the Selection tool to 
select it. 


9. Select Modify > Convert To Symbol. 


 The Convert To Symbol dialog box opens (Figure 6). 


10. In the dialog box, name the symbol eye, select Graphic 
as the behavior, and click OK. 


 The eye on the Stage is now just an instance (copy) of 
the master eye symbol, which is stored in the library. 
The eye now has a single blue selection border 
(Figure 7) and can be selected with a single click. 


 


 
Figure 5 Frame 1 selected 


 


 
Figure 6 Convert To Symbol dialog box 


 


 
Figure 7 Graphic symbol selected 
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11. Select Window > Library to see that your symbol has 
been added to the Library panel (Figure 8). 


 Note: You must select the eye symbol in the library to 
see the graphic in the preview window. 


 You can now reuse the eye symbol as many times as 
you want without redrawing it. 


 
Figure 8 Library panel 


Reuse the eye symbol to create the left eye 


12. Click the Insert Layer button in the lower left corner of 
the Timeline to insert a new layer (Figure 9). 


13. Double-click the layer name and change the name to 
Left Eye. 


14. On the Left Eye layer, select frame 1. 


15. Select the eye symbol in the Library panel and drag the 
symbol onto the Stage. 


 You now have a second instance of the eye on the Stage. 
Using instances from the library keeps the file size of 
your movie smaller than copying and pasting. Smaller 
movies load faster in a browser. 


 
 


Figure 9 Insert Layer button 


Draw the nose 


16. Insert a new layer and name it Nose. 


17. Select frame 1 on the Nose layer. 


18. Select the Line tool and draw two lines that form an 
angle to represent a nose (Figure 10). 


19. To adjust the angle after you’ve drawn it, use the 
Subselection tool (white arrow) to drag the corner or one 
end of the line. (You might try dragging one end of a 
line with the Arrow tool to see the difference between 
the two tools.) 


 
Figure 10 Draw nose 


Insert Layer button 
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Add frames to make a three-second movie 


A Flash movie typically plays 12 frames per second. To keep the nose on the Stage for 3 seconds, for example, you 
need to insert 36 additional frames on the Nose layer after frame 1, the current frame. (Starting at frame 1, it will 
take the movie 3 seconds to reach frame 37, because 1 + 36 = 37.) 


20. Select frame 37 on the Nose layer and select Insert > 
Timeline > Frame.  


 Flash inserts frames through frame 37 (Figure 11).  


 Observe that the playhead (the red rectangle at the top of 
the Timeline) is on frame 37 and that the nose is visible 
but the eyes have disappeared. At the bottom of the 
Timeline, you can see that this movie is currently 37 
frames, is set to play at 12 frames per second, and will 
play for 3 seconds. 


 Note: The keyboard shortcut for inserting a frame is F5.  


21. Drag the playhead to various frames. 


 The nose remains visible in frames 1 through 37, but the 
eyes appear only in frame 1. 


22. To see your movie, drag the playhead to frame 1 and 
then select Control > Play. 


 At this point, not much is happening beyond frame 1. 


 
Figure 11 Frame inserted in Timeline 


Draw the mouth 


23. Insert a new layer and name it Mouth. 


24. Select frame 1 of the Mouth layer. 


25. Draw a mouth in frame 1. 


• Use the Line tool to draw a straight line 
(Figure 12).  


• Select the Selection tool and click on the Stage 
away from the line to deselect it.  


• Move the pointer toward the middle of the line. 
When a curve appears next to the pointer, drag the 
middle of the line downward to create a smile 
(Figure 13).  


• When you release the mouse button, only the smile 
remains (Figure 14). 


 
Figure 12 Mouth as straight line 


 


 
Figure 13 Drag line with Arrow tool 
 


 
Figure 14 Mouth complete 
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Animate the facial features 


Use motion tweens to animate the eyes 


Because you created the eyes by using a graphic symbol, you can animate them by using a motion tween. To create 
the motion tween, you need to extend the Timeline in the Right Eye layer. 


1. On the Right Eye layer, select frame 37 and select 
Insert > Timeline > Frame (Figure 15).  


2. With the Right Eye layer selected, choose Insert > 
Motion Tween. 


3. Select frame 37 on the Right Eye layer and drag the 
right eye a short distance.  


 A motion path appears on the Stage showing the path 
from the position in the first frame of the tween span to 
the new position (Figure 16). Because you explicitly 
defined the X and Y properties of the object, property 
keyframes are added for X and Y in the frame 
containing the playhead. Property keyframes appear as 
small diamonds in the tween span on the timeline. 


4. Position the playhead on frame 1 and select 
Control > Play to play your movie and see the effect of 
the motion tween. 


 The right eye gradually moves from its original position 
in frame 1 to the new position in frame 37. Notice that 
only the right eye moves. 


 Note: If you want to change the motion, move only the 
symbol in keyframe 37. 


5. Choose frame 37 on the Left Eye layer and select 
Insert > Timeline > Frame.  


6. With the Right Eye layer selected, choose Insert > 
Motion Tween. In frame 37 move the left eye the same 
distance as the right eye. 


 
Figure 15 Tween span in the Timeline panel 


 


 
Figure 16 Tweened object with a motion path 
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Use a shape tween to animate the mouth 


Because you created the mouth by using one of the drawing tools (the Line tool) and have not converted the mouth 
to a symbol, it is still a shape. You can use a shape tween to animate the mouth. 


1. Select frame 37 on the Mouth layer and insert a 
keyframe. 


2. With the Selection tool, click on the Stage away from 
the mouth line to deselect it. Then drag the mouth line 
into a bigger smile. 


3. To create a shape tween between the first and last 
frames on the Mouth layer, click a frame between 
frames 1 and 37, and select Insert > Shape Tween. 


 The frames containing the shape tween are now light 
green and contain a solid arrow running from the start 
frame to the end frame (Figure 17).  


4. Select File > Save. 


5. Select Control > Test Movie to see it play. 


 Selecting Control > Test Movie exports a .swf file and 
plays it in a preview window. When the movie reaches 
the last frame, it loops back to frame 1 and plays again. 


6. Select File > Close to close the preview window. 


 
Figure 17 Shape Tween on the Mouth layer 


Create any additional animated facial features as you choose. 
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Publish your movie 
When you’re ready to deliver your movie to an audience, you can publish the Flash document (FLA file) for 
playback. The Publish command creates a Flash SWF file (playable with Flash Player) and an HTML document that 
inserts your Flash movie in a browser window. For viewers who do not have Flash Player installed, you can select to 
publish the FLA file in alternative file formats—GIF, JPEG, PNG, or QuickTime—with the HTML needed to 
display them in a browser window. 


When you publish HTML with your movie, Flash also creates a file called AC_OETags.js. This JavaScript file lets 
your SWF file play automatically in certain browsers (called active content-compliant browsers) that would 
otherwise require a site visitor to click to play your movie. To avoid this problem, upload AC_OETags.js to your 
site in the same location as the HTML file that hosts the movie. For more about this issue, visit 
www.adobe.com/go/activecontent. 


1. Select File > Publish Settings to open the Publish 
Settings dialog box (Figure 18). 


2. Use the Formats tab to determine which file formats to 
output when you publish. 


 


 
Figure 18 Publish Settings dialog box 



http://www.adobe.com/go/activecontent�
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3. Use the Flash tab to determine which Flash Player you 
are publishing to (Figure 19). If you think your 
audience might not have the latest player, you might 
want to select an older player from the Version menu. 


4. Select Generate Size Report to see a detailed report of 
size for each asset in your movie. 


5. Select Protect From Import to prevent anyone from 
importing your SWF file into Flash and converting it 
back to a FLA file. 


6. Select Compress Movie to reduce the file size of the 
exported movie. 


7. Use the HTML tab to control settings for the HTML file 
(Figure 20). 


8. Deselect the Loop option if you want your movie to play 
through only one time and stop. 


9. To publish your movie, click the Publish button. 


 
Figure 19 Flash tab of Publish Settings dialog box 


 


 
Figure 20 HTML tab of Publish Settings dialog 
box 
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How to create character animations 


Inverse Kinematic Poses 
Inverse kinematics (IK) is a method for animating an object or set of objects in relation to each other using an 
articulated structure of bones. Bones allow symbol instances and shape objects to move in complex and naturalistic 
ways with a minimum of design effort. For example, inverse kinematics lets you create character animation, such as 
arms, legs, and facial expressions much more easily. 


You can add bones to separate symbol instances or to the interior of a single shape. When one bone moves, the other 
connected bones move in relation to the bone that initiated the movement. When animating using inverse kinematics 
you need only specify the start and end positions of objects. Inverse kinematics lets you create natural motion much 
more easily. 


 
Figure 1 A shape with an IK armature added 


 


 
Figure 2 A group of several symbols with IK 
bones attached 


A chain of bones is called an armature. The bones in an armature are connected to each other in a parent-child 
hierarchy. An armature can be linear or branched. Branches of an armature that originate at the same bone are called 
siblings.  


You can use IK in Flash in two ways. The first is to articulate a series of symbol instances by adding a single bone to 
each instance. The bones allow the chain of symbol instances to move together. For example, you might have a set 
of movie clips that each represents different parts of a human body. By linking the torso, upper arm, lower arm, and 
hand together, you can create a realistically moving arm. You can create a branched armature to include both arms, 
both legs, and the head. 


The second way to use IK is to add an armature to the interior of a shape object. The shape can be created in merge 
drawing mode or object drawing mode. The bones allow you to move and animate parts of the shape without the 
need to draw different versions of the shape or create a shape tween. For example, you could add bones to a simple 
drawing of a snake to enable the snake to move and curve realistically.  


When you add bones to symbol instances or shapes, Flash moves the instance or shape and the associated armature 
to a new layer in the Timeline. This new layer is called a pose layer. Each pose layer can contain only one armature 
and its associated instances or shape. 


Flash includes two tools for working with IK. You add bones to symbol instances and shapes with the Bone tool. 
You use the Bind tool to adjust the relationships between individual bones and control points of shape objects.  


You can animate armatures and their associated symbols or shapes either in the Timeline or with ActionScript 3.0. 
You animate in the Timeline by defining different poses for the armature in different frames. Flash interpolates the 
positions of the armature in the frames in between. For information about animating armatures with ActionScript, 
see the fl.ik classes in the ActionScript 3.0 Language and Components Reference.  
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Note: To use inverse kinematics, your FLA file must specify ActionScript 3.0 as the Script setting in the Flash tab 
of the Publish Settings dialog box. 


To add IK bones and poses: 


1. Start Flash and select File > New.  


2. On the General tab, select Flash File (ActionScript 3.0) 
and click OK. 


3. Begin by creating and arranging on the stage multiple 
shapes in a rough spatial configuration of the object you 
wish to animate using IK. 


4. Convert them all of the shapes on the stage to symbol 
instances (Figure 3). In this example, symbols have 
been arranged to form a muscle man. 


5. Select the Bone tool from the Tools panel. 


 You can also press the X key to select the Bone tool. 


6. With the Bone tool, click the symbol instance that is to 
be the root or head of the armature. Then drag to a 
separate symbol instances to link it to the root instance. 


 As you drag, a bone appears. When you release the 
mouse, a solid bone exists between the two symbol 
instances. Each bone has a head (the round end) and a 
tail (the pointed end). Each symbol instance can have 
only one attachment point. You can edit these 
attachment points later. 


 When dragging from one instance to another to create a 
bone, click the first instance at the specific point where 
you want to attach the bone to the instance. Release the 
mouse over the specific point on the second instance 
where you want the bone to attach. You can also edit 
these attachment points later. 


 The first bone in an armature is the root bone. It has a 
circle around the head of the bone. 


 By default, Flash moves the transformation point of 
each symbol instance to the location of the joint formed 
by each bone connection. For the root bone, the 
transformation point moves to the head of the bone. For 
the last bone in a branch, the transformation point moves 
to the tail of the bone. You can disable the automatic 
movement of the transformation point on the Drawing 
tab by selecting Edit > Preferences (Windows) or Flash 
> Preferences (Mac OS). 


 


 
Figure 3 Symbol instances on the Stage 
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6. To add another bone, drag from the tail of the first bone 
to the next symbol instance you want to add to the 
armature. 


 The pointer changes when you roll over the head or tail 
of an existing bone. 


 Link objects with bones in the order of the parent-child 
relationships you want to create (Figure 4). 


 You can move (Figure 5) add, delete, and edit control 
points of the contours in an IK shape by using the 
Subselection tool (Figure 5). 


• To move the position of a bone without changing 
the IK shape, drag the endpoint of the bone. 


• To display the control points of the IK shape 
boundary, click the stroke of the shape. 


• To move a control point, drag the control point. 


• To add a new control point, click a part of the stroke 
without any control points. 


 You can also use the Add Anchor Point tool in the Tools 
panel. 


 To delete an existing control point, click to select it, and 
then press the Delete key. 


 You can also use the Delete Anchor Point tool in the 
Tools panel. 


 As you add bones to instances, Flash moves each 
instance to a new layer in the Timeline. The new layer is 
called a pose layer (Figure 6). All the bones and symbol 
instances associated with a given armature reside in the 
pose layer. Each pose layer can contain only one 
armature. Flash adds the new pose layer to the Timeline 
between existing layers to maintain the previous 
stacking order of objects on the Stage. 


 
Figure 4 Linking symbols with the Bones tool 


 


 
Figure 5 Moving linked objects with the 
Subselection tool 


 


 
Figure 6 Pose layer  
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 You can now animate this character and keep the 
relationship between the symbols by using the bones 
you have created. 


7. Insert a Pose in the Armature layer at frame 10 by right-
clicking (Windows) or Control-clicking (Mac OS) the 
frame and selecting Insert Pose (Figure 7). 


8. Rearrange this pose as you like. 


9. Select Control > Test Movie to preview the movie. The 
symbols move in relation to each other. You can fine-
tune this movement by shifting the anchor points in the 
bones. 


10. Select File > Close to close the preview window. 


11. Save the movie. 


12. Close the movie. 


 
Figure 7 Insert Pose 
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Analyzing Flash on the web 
Student name:  ________________________________________________ Date:  _______________________  


Examine some websites that use Adobe Flash CS4 to see examples of the techniques designers use to target a variety 
of audiences. Use this worksheet to record your observations. 


URL:  _______________________________________________________________________________________  


Name of the site:  ______________________________________________________________________________  


What is the main type of audience the site is targeting? How does the site target this audience? 


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


Identify the following Flash techniques and explain what part of the site uses them: 


Motion tweens 


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


Shape tweens 


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  
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Movie clips 


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


Buttons 


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


Sound (How many sounds do you hear? How many times does the sound seem to loop?) 


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


stop actions 


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


go to and play actions 


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  
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Combinations of symbols (such as buttons that contain animated movie clips) 


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


Challenge: 


For the complicated effects you see, suggest combinations or types of technical techniques that might be involved to 
create them. 


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


Describe a surprising technique. 


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


Describe a challenging technique. 


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  
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Describe unidentified techniques. 


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


Describe a creative design. 


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  


 ____________________________________________________________________________________________  
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How to produce Flash video for use on the web 
Adobe Flash CS4 provides a number of options for importing and publishing video with a Flash movie. 


You can import the following video formats: 


• Video for Adobe Flash (.flv, .f4v) 


• 3GPP/3GPP2 for mobile devices (.3gp, .3gpp) 


You can import the following video formats if you have QuickTime 7 or later installed (Windows and Mac OS): 


• Audio Video Interleaved (.avi) 


• Digital Video (.dv) 


• Motion Picture Experts Group (.mp4, .m4v, .avc) 


• QuickTime Movie (.mov, .qt) 


You can import the following file formats if you have DirectX 9 or later installed (Windows only): 


• Audio Video Interleaved (.avi) 


• Motion Picture Experts Group (.mpg or .mpeg) 


• Windows Media File (.wmv, .asf) 


Deploying video 
How you choose to deploy your video determines how you create your video content and how you integrate it with 
Flash. You can incorporate video into Flash in the following ways: 


Progressively download video from a web server: Flash creates a Flash video file that downloads from a regular web 
server and plays within the published SWF file. 


Stream video with Adobe Flash Media Server: This option produces the overall best performance; however, it 
requires either the Flash Media Server or a subscription to a Flash Video Streaming service. See the Adobe website 
for more information: www.adobe.com. 


Embed video in the Flash document: You can embed a small, short-duration video file directly into the Flash 
document and publish it as part of the SWF file. Embedding video content directly into the Flash SWF file 
significantly increases the size of published file and is only suitable for small video files (typically less then 
10 seconds in length). 


To encode your video for Flash: 


1. Open an existing Flash document or create and save a 
new Flash document. 


 Note: You must save the Flash document before you 
begin the video import process. 


2. Select a keyframe on the layer in which you want to 
import the video. 


 This is where the video player will be located after the 
video import is complete. 


 



http://www.adobe.com/�
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3. Click File > Import > Import Video. 


 The import Video dialog box appears (Figure 1). 


4. Click the Launch Adobe Media Encoder button. 


 The Adobe Media Encoder appears (Figure 2). 


5. In the Media Encoder, click the Add button and browse 
to the location for the video file you want to encode. 


6. Choose an appropriate Format, Preset (Figure 3), and 
Output File location in the Media Encoder. 


7. Click the Start Queue button to begin encoding. 


 When the encoding process is complete, close the Adobe 
Media Encoder.  


 


 
Figure 1 Import Video dialog box  


 


 
Figure 2 Adobe Media Encoder 


 


 
Figure 3 Preset options for encoding video 
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To use progressive download: 


1. Click File > Import > Import Video. 


 The import Video dialog box appears (Figure 4). 


 2. Click the browse button to find the location for the 
newly encoded video file you want to import. 


 You can use a video file located either on your computer 
or on the Internet. 


3. Select Load External Video With Playback Component. 


 This option progressively loads your external video file 
into your Flash document. 


4. Click Next (Windows) or Continue (Mac OS). 


 The Skinning page of the Import Video wizard appears 
(Figure 5). 


 The video’s skin determines the location and appearance 
of the video controls. Visitors see this skin when Flash 
plays the video. 


5. Select a skin from the Skin pop-up menu. 


6. Select a skin color from the color picker. 


7. Click Next (Windows) or Continue (Mac OS). 


 The Finish Video Import page of the Import Video 
wizard appears. This page confirms the location of the 
Flash video file. 


8. Click Finish. 


 The FLVPlayback object appears on the Stage 
(Figure 6). 


9. Select Control > Test Movie to see it play. 


 The video plays in the Flash Player window. You can 
use the controls to stop, pause, fast forward, rewind, and 
change the volume of the video. 


10. Select File > Close to close the preview window. 


11. Open the folder in which you saved the Flash document. 


 This folder now contains two new files: an FLV file and 
a SWF for the video’s skin. (The skin will be called 
something like MojaveOverAll.swf.) When you publish 
your Flash document, you need to copy both of these 
files to the same location as the Flash document. 


 
Figure 4 Import Video wizard, Select Video page 


 


 
Figure 5 Import Video wizard, Skinning page 


 


 
Figure 6 FLVPlayback object on Stage 
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Embedding video within SWF files 


When you select the embedded video option, Flash converts video to Timeline frames. When the SWF file is 
published, the video is fully contained in that file. Unlike progressive download, embedded video requires no 
external file and so is easier to deploy. However, because embedded video often has problems with audio 
synchronization after 120 frames, Adobe recommends embedded video in only three cases: 


• When you want visitors who have Flash 5 to be able to view your video 


• When you must have one single file that encapsulates the video and the Flash content 


• When your video clip is less than 5 seconds long 


These situations are not common. In all other situations, embedded video is not recommended. 
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Analyzing Flash on the web 
This sample analysis of a Flash website illustrates some techniques designers use to target a specific audience. 
 


URL: georgewashington.si.edu/ 


Name of the site: George Washington: A National Treasure 


What is the main type of audience the site is targeting? How does the site target this audience? 


The main audience is teachers who might use the information on this site for a unit on George Washington, history, 
culture, or art. 


 


Identify the following Flash techniques and explain what part of the site uses them: 


Motion tweens 


When you launch the site, the white and red bars that expand and contract are a motion tween, as is the white star 
that appears. 


 


Shape tweens 


The white star that turns into the profile of George Washington is possibly a shape tween. 


 


Movie clips 


The rotating star that appears when your pointer is over the words “Explore the Portrait” is a movie clip. 


 


Buttons 


After you enter the portrait and click “Explore the Portrait,” the boxes at the top of the portrait, labeled Symbolic, 
Biographic, and Artistic, are all buttons. The numbers that appear on the portrait are also buttons. 


 


Sound (How many sounds do you hear? How many times does the sound seem to loop?) 


There are no sounds in the portrait. 


 


stop actions 


There is probably a stop action placed after the red and white stripes complete their motion tweens, to hold visitors 
at a screen before they decide to enter the portrait. 


 


go to and play actions 


There is most likely a go to and play action set on each of the main buttons over the portrait and the numerical 
buttons on the portrait. 


 


Combinations of symbols (such as buttons that contain animated movie clips) 


The “Enter the Portrait” button on the initial screen is a combination of a button and a movie clip, because the 
movie clip appears only when the pointer is over the button. 
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Challenge: 


For the complicated effects you see, suggest combinations or types of technical techniques that might be involved in 
creating them. 


When the pointer rolls over one of the numbers on the portrait, these buttons fade all other parts of the image out 
and highlight the section of the image to which the number is attached. These buttons most likely contain an action 
that calls a movie clip to begin playing when the Over state is reached on the button. The movie clip fades out all 
aspects of the picture except the aspect related to the number you select. 


 


Describe a surprising technique. 


The magnifying glass is a surprising technique that adds to the overall feel of the site. Drag the pane up from the 
bottom of the portrait to magnify the portion of the portrait under the pane. 


 


Describe a challenging technique. 


The magnifying glass is a challenging technique. It most likely involves the use of programming with ActionScript. 


 


Describe unidentified techniques. 


It is difficult to tell how the magnifying glass might be achieved. 


 


Describe a creative design. 


A creative effect is the fading out and zooming in on aspects of the portrait when you click a number button. 
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How to use guides and rulers 


Using guides 
You can drag horizontal and vertical guides from the rulers onto the Stage when the rulers are displayed. You can 
move guides, lock guides, hide guides, and remove guides. You can also snap objects to guides and change the guide 
color and snap tolerance (how close objects must be to snap to a guide). Adobe Flash CS4 enables you to create 
nested Timelines (i.e., movie clips within the main movie). Guides appear on the Stage only when the Timeline in 
which they were created is active. 


To create a guide: 


1. Make sure rulers are visible by selecting View > Rulers.  


2. Click on a ruler and drag toward the Stage (Figure 1). 


 A guide appears as you drag. 


3. Release the mouse button at the point you wish to locate 
the guide (Figure 2).  


Figure 1 Drag a ruler 


 


 
Figure 2 Guide on Stage 
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To lock or unlock guides: 


• Select View > Guides > Lock Guides. 


 This command toggles between locking and unlocking 
guides. When guides are locked, they won’t respond to 
clicking or dragging, so that you won’t accidentally 
move them when you are working with objects on the 
Stage. However, you can still create new guides. 


 Note: You can also use the Lock Guides option in the 
Guides dialog box (View > Guides > Edit Guides). For 
more information, see the section titled Changing guide 
properties at the end of this guide. 


To view or hide the drawing guides: 


• Select View > Guides > Show Guides. 


To move a guide: 


• Make sure guides are not locked. With the Selection 
tool, click anywhere on the guide and drag the guide to 
the desired place on the Stage. 


To remove a guide: 


• With guides unlocked, use the Selection tool to drag the 
guide to the horizontal or vertical ruler. 


 


Using guides to position objects on the Stage 


1. Select View > Snapping > Snap To Guides. 


2. Drag the edge of an object toward a guide. 


 When you get close to the guide, the object snaps to it 
(Figure 3). 


3. Release the mouse. 


 The object remains snapped to the guide. 


 You can use guides to line up different objects 
(Figure 4). Guides are especially useful for aligning 
objects on different layers. 


 
Figure 3 Snap object to grid 


 


 
Figure 4 Aligning objects with guides 
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Changing guide properties 
You can change guide colors, set guide snapping properties, and lock guides. 


1. Select View > Guides > Edit Guides. 


 The Guides dialog box opens (Figure 5). 


2. Click the Guides Color control to change guide colors. 


3. Select Lock Guides to lock guides in position. 


4. Click OK to close the Guides dialog box. 


  
Figure 5 Guides dialog box 
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How to get started with ActionScript 
ActionScript 3.0 is the scripting language of Adobe Flash CS4. You can use ActionScript to add complex 
interactivity, playback control, and data display to your application. For example, you might want to animate a 
picture of a boy walking. By adding ActionScript, you could have the animated boy follow the pointer around the 
screen, stopping whenever he collides with a piece of animated furniture. 


ActionScript is an object-oriented programming language. Object-oriented programming is a way to organize the 
code in a program, using code to define objects and then sending messages back and forth between those objects. 


You don’t have to be a programmer to take advantage of ActionScript (see “Using Script Assist mode” later in this 
guide). But the following concepts will help: 


• Class: The code that defines an object. This code consists of properties, methods, and events. Think of the 
blueprint of a house: you can’t live in the blueprint, but you need it so you can build the house. You use 
classes to create objects. 


• Object: An instance of a class. When you instantiate an object (create an instance of it), you declare what 
class it is created from and set its properties. You can create as many objects as you want from a single 
class—if you have a bicycle


• Property: One of the pieces of data bundled together in an object. A property helps define an object—it 
provides the object’s characteristics. A song object might have properties named 


 class, you can create many bicycle objects, each with its own properties 
(one bicycle might be red while another might be green). 


melody and title


• Variable: 


. 
You set the properties of an object when you create the object, but you can change them later as needed. A 
property is a variable that belongs to an object. 


A name that represents a value in the computer’s memory. As you write code, you write the 
variable’s name as a placeholder for the value. This allows you to write code even if you don’t know all the 
possible values a visitor might provide. If you create a variable firstName


• Method: An action that can be performed by an object. For example, the class 


, you can tell your program to 
display the visitor’s first name without knowing in advance what the visitor’s first name is. 


horse might have a method 
called gallop(). When the method gallop()


• Function: A block of code that carries out specific tasks and can be reused in your program. For example, 
you might create a function called 


 is called, it shows an animation of the horse galloping 
from one point to another. 


checkEmail() to verify that text typed by a visitor is a valid e-mail 
address. Each time a visitor provides an e-mail address, you can call checkEmail()


• Event: Something that happens in a Flash movie that ActionScript is aware of and can respond to. Many 
events are related to user interaction—for example, a user clicking a button or pressing a key on the 
keyboard. The technique for specifying certain actions that should be performed in response to particular 
events is known as event handling. 


 to make sure the 
visitor has provided text that can actually be used as an e-mail address. If you ever want to update the 
function, you only have to do it once instead of in each place where e-mail addresses must be validated. 
You can also think of a method as a function attached to an object. 


If you’ve worked with symbols in Flash, you’re already used to working with objects. Imagine you’ve defined a 
movie clip symbol—say a drawing of a rectangle—and you’ve placed a copy of it on the Stage. That movie clip 
symbol is also an object in ActionScript; it’s an instance of the MovieClip class. The main timeline of a Flash movie 
also belongs to the Movie Clip class. 


You can modify various characteristics of any movie clip. When a movie clip is selected, the Property inspector 
shows some of the characteristics you can change, such as its X coordinate or its width. Or you can make color 
adjustments such as changing the clip’s alpha (transparency). Other Flash tools let you make more changes, such as 
using the Free Transform tool to rotate the rectangle. All of the ways you can modify a movie clip symbol in the 
Flash authoring environment are also things you can do in ActionScript. In ActionScript, you use the methods of the 
MovieClip class to manipulate or change the properties of your movie clip. 
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For more about object-oriented programming, see Programming ActionScript 3.0, “Object-oriented Programming in 
ActionScript” (in Flash, select Help > Flash Help). 


Using Script Assist mode 
You can add ActionScript in the authoring environment by using the Actions panel (Figure 1). The Actions panel 
provides Script Assist mode to simplify the coding process. 


 
Figure 1 Actions panel in Script Assist mode 


In Script Assist mode, you can add ActionScript to your Flash document without writing the code yourself. You 
select actions from the Actions toolbox and set the options for each action in the parameters area. You must know a 
little about what functions to use to accomplish specific tasks, but you don’t have to learn syntax (the grammar of 
ActionScript). Many designers and nonprogrammers use this mode. 


One of the first things to learn is how to stop your movie at a certain spot. You will also learn how to send the 
playhead to a particular frame in the movie. 


Parameters area 


Actions toolbox 


Script navigator 


Script pane 


Script Assist button 
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Using ActionScript to stop a movie 


1. Start Flash and open a movie. Create a layer in your 
movie named actions. In the frame that corresponds to 
the end of your movie, insert a new keyframe. 


2. Select Window > Actions to display the Actions panel. 


3. If you don’t see the parameters area in the Actions 
panel, click the Script Assist button in the upper-right 
corner (Figure 2). 


 Classes are organized into packages. You want to add a 
stop() action to a movie clip (in this case, your 
timeline is the movie clip), so you must locate the 
Movie Clip class. The Movie Clip class is part of the 
Flash.Display package. 


4. In the Actions toolbox on the left side of the Actions 
panel, scroll down and click the Flash.Display package 
to display the classes it contains. 


5. Scroll down again to find the Movie Clip class and click 
to expand it (Figure 3). 


6. Click Methods to view the methods available for the 
Movie Clip class. 


 


 
Figure 2 Actions panel 


 


 
Figure 3 Movie Clip class 


 


Script Assist button 
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7. Scroll down to the Stop method. Do one of the 
following:  


• Double-click the Stop method. 


• Drag the Stop method into the Script pane. 


 Code for applying the Stop method appears in the Script 
pane (Figure 4). The first line (import 
flash.display.MovieClip();) imports the 
code necessary for the Movie Clip class. The second line 
is the Stop action itself. The red code not_set_yet 
indicates you should use Script Assist to finish the code. 


8. Click in the Object field in the parameters area of the 
Actions panel. 


 The Insert Target Path button is now active. The target 
path helps you locate the object you are trying to 
control. 


9. Click the Insert Target Path button. 


 The Insert Target Path dialog box appears (Figure 5). 


10. Select the Relative option and click Root. 


 This sets the target path to this. 


11. Click OK to close the Insert Target Path dialog box. 


 The completed script for the Stop method appears in the 
Script pane (Figure 6). This code will cause your movie 
to stop playing at the end of the movie, frame 40. 


 Note: In ActionScript, this is used the same way that 
you would refer to yourself as “me” instead of using 
your full name. Remember that the main timeline is an 
instance of the MovieClip class. In Figure 6, Flash uses 
this


 


 to refer to the movie clip that frame 40 belongs to. 


12. Close the Actions panel. 


 
Figure 4 Stop method 


 


 
Figure 5 Insert Target Path dialog box 


 


 
Figure 6 Stop method applied to frame 40 


 


Frame number 


Insert Target Path button 
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Event handling 
The technique for specifying certain actions that should be performed in response to particular events is known as 
event handling. Event handling consists of three important elements: 


• The event source: Which object will trigger the event? For example, which button will be clicked, or which 
Loader object is loading the image? 


• The event: What is going to happen, what interaction do you want to respond to? Identifying the event is 
important, because an object can trigger (and listen for) several events. 


• The response: What action(s) do you want performed when the event happens? 


When an ActionScript program is running, Adobe Flash Player just sits and waits for certain events to happen, and 
when those events happen, the player runs the specific ActionScript code you’ve specified for those events. For the 
program to know what events are important, you must create an event listener. An event listener is a function Flash 
Player executes in response to specific events. 


Adding an event listener is a two-step process: 


• First, you create a function or class method for Flash Player to execute in response to the event. This 
function is sometimes called the listener function. 


• Second, you use the addEventListener() method to connect the listener function with the target of the event. 
The addEventListener() function tells Flash what object to listen to, what event to listen for, and what 
function to execute in response. 


Using ActionScript to go to another frame 


1. Create a button users can click to go to a particular 
frame in your movie. Make sure you place the button on 
the Stage (Figure 7). 


2. Select the button and use the Property inspector to give 
the button a unique instance name (Figure 8). 


3. In the main timeline of your movie, create a layer named 
actions. 


4. Create a keyframe in the actions layer that corresponds 
to the keyframe where your button first appears on the 
Stage. Select this keyframe in the actions layer. 


 Note: If your button doesn’t appear in this frame, Flash 
will generate an error message because you are referring 
to an object that isn’t on the Stage yet. 


5. Select Window > Actions to display the Actions panel. 


6. If you don’t see the parameters area in the Actions 
panel, click the Script Assist button. 


7. In the Actions toolbox on the left side of the panel, 
select the AddEventListener method from the 
IEventDispatcher class. 


 To find the AddEventListener method, open 
flash.events, and then open IEventDispatcher. 


 
Figure 7 Button instance 


 


 


 
Figure 8 Button instance 


 


 


Instance name 
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8. Double-click the AddEventListener method to add it to 
the Script pane (Figure 9). 


9. Click in the Object field in the parameters area of the 
Actions panel. 


 The Insert Target Path button is now active. 


10. Click the Insert Target Path button. 


 The Insert Target Path dialog box appears (Figure 10). 


11. Select the Relative option and select the instance name 
of your button. Click OK to close the dialog box. 


 The event listener is attached to the instance of your 
button (Figure 11).  


 Next, you select an event to listen for. 


 
Figure 9 AddEventListener method in the Actions 
toolbox 


 


 
Figure 10 Insert Target Path dialog box 


 


 
Figure 11 Event listener code in the Script pane 
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12. In the Actions toolbox on the left side of the panel, 
select the CLICK property from the MouseEvent class 
(Figure 12). 


 To find the CLICK property, open Flash.Events, open 
MouseEvent, and open Properties. 


13. In the Script pane, select the AddEventListener() line to 
display the parameters for this method. Then, in the 
parameters area, click in the Type field. 


14. In the Actions toolbox, double-click the CLICK 
property. 


 Script Assist adds the property to your code as 
MouseEvent.CLICK


 Now your code will listen for a click on the button. To 
tell the event listener how to respond when that click 
occurs, you next create a function. 


 (Figure 13). 


15. In the parameters area, type a name for your function in 
the Listener field. You can use any name you like, but 
make sure the name of the function is unique and 
contains no spaces (Figure 14). 


 The function name appears in the Script pane as you 
type. You have named the function, but you haven’t 
created it yet. 


16. In the Actions toolbox, select the function


 To find the 


 keyword 
from Language Elements. 


function


17. Double-click the function keyword in the Actions 
toolbox. 


 keyword, expand Language 
Elements. Then expand Statements, Keywords & 
Directives, and expand Definition Keyword. 


 The code for creating a function appears in the Script 
pane (Figure 15). 


18. In the parameters area of the Script pane, type the name 
of your function in the Name field. 


 Note: The function name must be typed exactly as you 
typed it for the AddEventListener function in step 15. 
Function names are case-sensitive. 


19. In the parameters area of the Script pane, type 
event:MouseEvent in the Parameters field. 


 In this field, you are naming a variable (event) and 
indicating what type of variable it is (MouseEvent). 


 
Figure 12 CLICK property in the Actions toolbox 


 


 
Figure 13 CLICK property in the Script pane 


 


 
Figure 14 Function name in the Listener field 


 


 
Figure 15 Function code 
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20. In the parameters area of the Script pane, select Void 
from the Type pop-up menu. 


 Some functions return a value when called. The 
keyword void


 Now you can tell the function what you want it to do 
when the CLICK event occurs. 


 indicates that this function does not 
return a value. 


21. In the Actions toolbox on the left side of the panel, 
select the GotoAndPlay method for the Flash.Display 
class (Figure 16). 


 To find the GotoAndPlay method, expand 
Flash.Display, and then expand MovieClip. 


22. Select the function in the Script pane and double-click 
the GotoAndPlay method in the Actions toolbox. 


 The method is added to the function (Figure 17). 


23. Click in the Object field in the parameters area of the 
Actions Panel. 


 The Insert Target Path button is now active. 


24. Click the Insert Target Path button to display the Insert 
Target Path dialog box. 


25. Select the Relative option and select the movie clip you 
want to play when the button is clicked. If you want the 
movie in the main timeline to play, select Root to set the 
target path to this


26. Click OK to close the Insert Target Path dialog box. 


. 


27. In the Frame field, type the number of the frame you 
want to send the playhead to. For example, if you want 
the movie to start from the beginning, type the number 1 
to play the movie’s first frame. 


28. Close the Actions panel. 


29. Save the movie. 


30. Select Control > Test Movie to test the movie. 


31. Select File > Close to close the preview window. 


 
Figure 16 GotoAndPlay method 


 


 
Figure 17 GotoAndPlay method in the Script pane 


 


For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, 
select Help > Flash Help). 
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Symbols, instances, and the library 


Symbols and instances 
A symbol is a graphic, button, or movie clip you create once in Adobe Flash CS4 and can use any number of times 
throughout your movie. Any symbol you create is automatically placed in a storage area called the library for the 
current document. 


An instance is a copy of a symbol located on the Stage. An instance can be different from its symbol in color, size, 
and function. To create an instance of a symbol, drag the symbol from the library onto the Stage. Once you have 
created an instance, you can use the Color options in the Property inspector to change its brightness, tint, alpha, or 
RGB color settings. 


Editing the symbol automatically updates all of its instances, but applying effects to an instance of a symbol updates 
only that instance. 


Using symbols offers a number of advantages. Symbols add interactivity to your documents. They save space and 
reduce the download time of your finished movie because Flash does not have to save duplicate information for each 
instance. For example, if you create an animated wheel symbol, you can use several instances of the symbol to 
create the wheels on a train. The result is a much smaller file than if you had created each wheel separately. Symbols 
also help you maintain consistency throughout your Flash document. For example, if you have buttons throughout 
your document, using symbols ensures that all buttons look alike. You can easily edit all instances of buttons in a 
document at once when you use symbols to create them. You can also use symbols to share content between 
different documents. 


When you create a new drawing in Flash, you’re creating a shape, not a symbol. You can convert any shape to a 
symbol by selecting it and then selecting Modify > Convert To Symbol. 


Libraries 
The library is a container in each movie where Flash stores and organizes symbols, sounds, bitmap graphics, video, 
and other elements. The library is attached to the document you’re working on. To open the Library panel, select 
Window > Library (Figure 1). If you share your document with someone else, and they open it on their computer, 
they will see the same library objects. You can also open libraries from other documents by selecting File > 
Import > Open External Library. As your documents become more complex, you’ll find it helpful to use folders to 
sort your symbols into related groups within the library. 


 
Figure 1 Library panel 
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Types of symbols 
Flash has three types of symbols: graphic, button, and movie clip. 


Each symbol has a unique Timeline and Stage, complete with layers. When you create a symbol, you choose the 
symbol type, depending on how you want to use the symbol in your document. 


• Use graphic symbols for static images and to create reusable pieces of animation that are tied to the main 
Timeline. Graphic symbols operate in sync with the main Timeline. Interactive controls and sounds won’t work 
in an animation sequence contained in a graphic symbol. 


• Use button symbols to create interactive buttons that respond to mouse clicks, rollovers, and other site visitor 
actions. You define the graphics associated with various button states and then assign actions to a button 
instance. 


• Use movie clip symbols to create reusable pieces of animation. A movie clip has its own Timeline that is 
independent from the main Timeline—think of it as a sub-Timeline nested inside the main Timeline. Movie 
clips can contain interactive controls, sounds, and even other movie clip instances. 


Creating symbols 
You create symbols in one of two ways: 


• Select Insert > New Symbol. This creates a new symbol to which you must add content. 


• Select an existing shape and select Modify > Convert To Symbol. 
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Working with symbols 
A symbol is a reusable object stored in a library for an Adobe Flash CS4 document. It can be as simple as a static 
drawing or as complex as a movie clip that runs within another movie clip. Both you and the Flash Player can reuse 
symbols stored in the library. Not only does this approach speed development, it also helps keep your document 
small, making it faster for site visitors to download. 


Each symbol has its own Timeline. You can add frames, keyframes, and layers to a symbol Timeline, just as you can 
to the main Timeline. 


An instance is a copy of a symbol located on the Stage or inside the Timeline of another symbol. An instance can 
differ from its symbol in color, size, and other characteristics set through the Property inspector. Editing the symbol 
updates all its instances, but applying effects or changing the properties of an instance of a symbol changes only that 
instance. 


Types of symbols 
Each symbol has a unique Timeline and Stage, complete with layers. You can add frames, keyframes, and layers to a 
symbol Timeline, just as you can to the main Timeline. When you create a symbol you choose the symbol type.  


• Use graphic symbols for static images and to create reusable pieces of animation that are tied to the main 
Timeline. Graphic symbols operate in sync with the main Timeline. Interactive controls and sounds won’t 
work in a graphic symbol’s animation sequence. Graphic symbols add less to the FLA file size than buttons 
or movie clips because they have no timeline. 


• Use button symbols to create interactive buttons that respond to mouse clicks, rollovers, or other actions. 
You define the graphics associated with various button states, and then assign actions to a button instance. 
For more information, see Handling events in Learning ActionScript 2.0 in Adobe Flash or Handling events 
in Programming ActionScript 3.0. 


• Use movie clip symbols to create reusable pieces of animation. Movie clips have their own multiframe 
Timeline that is independent from the main Timeline—think of them as nested inside a main Timeline that 
can contain interactive controls, sounds, and even other movie clip instances. You can also place movie clip 
instances inside the Timeline of a button symbol to create animated buttons. In addition, movie clips are 
scriptable with ActionScript®. 


Creating a new symbol 
You can create a symbol from selected objects on the Stage, create an empty symbol and make or import the content 
in symbol-editing mode, and create font symbols in Flash. Symbols can contain all the functionality that Flash can 
create, including animation.  


Flash adds the symbol to the library and switches to symbol-editing mode. In symbol-editing mode, the name of the 
symbol appears above the upper left corner of the Stage, and a cross hair indicates the symbol’s registration point. 
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To create a new symbol: 


1. Open an existing Flash document or create and save a 
new Flash document. 


2. Select Insert > New Symbol. 


 The Create New Symbol dialog box appears (Figure 1). 


3. In the Create New Symbol dialog box, give the new 
symbol a name and select a symbol type. 


4. Click OK. 


 The new symbol has been created and opens in symbol-
editing mode. 


5. Add content to the symbol. 


6. To exit symbol-editing mode and return to the main 
Timeline, click Scene 1 on the edit bar (Figure 2). 


 The new symbol is stored in the Document library and 
can be reused in this and other Flash documents. 


 
Figure 1 Create New Symbol dialog box 


 


 
Figure 2 Edit bar 


Converting an existing object to a symbol 


An existing object on a stage can be easily converted to a symbol. 


To convert an object to a symbol: 


 


1. Select the object you want to convert to a symbol. 


 Note: To select both the stroke and the fill of a shape, 
you must double-click the fill unless the object is 
grouped. A single click on the fill selects only the fill, a 
single click on a stroke selects one side of a stroke 
where a double click on the stroke selects the complete 
stroke. 


2. Select Modify > Convert To Symbol. 


 The Convert To Symbol dialog box appears (Figure 3). 


3. In the Convert To Symbol dialog box, give the new 
symbol a name, and select a symbol type. 


 The object is now a symbol that is stored in the 
Document library and can be reused in this and other 
documents. 


4. Select Window > Library to display the Library panel 
and see your new symbol. 


 
Figure 3 Convert To Symbol dialog box 


Editing a symbol 
You can edit an existing symbol either through the Library panel or in place on the Stage. You can also use the Edit 
In Place command to edit a symbol. By using the Edit In Place command, you can edit a symbol while still viewing 
other objects on the Stage. Editing a symbol is different from changing the properties of a symbol instance. When 
you click a symbol on the Stage and change its properties, you are changing the symbol instance, not the symbol 
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itself. In this case, only the instance is affected. When you edit the symbol itself, all instances of the symbol are 
affected. 


Editing a symbol in place 
To edit a symbol in place, you can double-click an instance of the symbol on the Stage or you can select an instance 
of the symbol on the Stage and right-click (Windows) or Control-click (Mac OS) and then select Edit In Place. You 
can also select Edit > Edit In Place to edit a symbol. 


Editing a symbol through the library 


When you edit a symbol through the library, Flash updates all instances of the symbol on the Stage. If the symbol 
has no instances (that is, if you have not copied it from the Library panel to the Stage), nothing on the Stage changes 
when you edit the symbol. 
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Using symbols with the Deco drawing tool 
By using the Decorative drawing tools, you can turn your symbols into complex, geometric patterns. The Decorative 
drawing tools apply algorithmic calculations, known as procedural drawing, to movie clips or graphics symbols in 
the library. In this way, you can create a complex pattern by using any graphics shape or object. 


The Symmetry effect 


Use the Symmetry effect to arrange symbols symmetrically around a central point. 


To apply the Symmetry effect: 


1. Select the Deco drawing tool, and select Symmetry 
Brush effect from the Drawing Effect menu in the 
Property inspector (Figure 4). 


2. In the Property inspector, click the Edit button. 


 The Swap Symbol dialog box appears, with a list of 
custom symbols from the library (Figure 5). 


 You can use any movie clip or graphics symbol in the 
library with the Symmetry Brush effect. This symbol-
based effect gives you a great deal of creative control 
over artwork you create in Flash. 


3. Select a symbol in the Swap Symbol dialog box and 
click OK. 


 
Figure 4 Drawing Effect menu in the Property 
inspector 


 


 
Figure 5 Swap Symbol dialog box 
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4. In the Property inspector, choose one of the options 
from the Advanced Options menu (Figure 6).  


• Rotate Around Point: Rotates the shapes in the 
symmetry around a fixed point that you designate. 
The default reference point is the center point of the 
symmetry. To rotate the object around its center 
point, drag in a circular motion. 


• Reflect Across Line: Flips the shapes an equal 
distance apart across an invisible line that you 
specify. 


• Reflect Around Point: Places two shapes an equal 
distance apart around a fixed point that you specify. 


• Grid Translation: Creates a grid by using the shapes 
in the Symmetry effect you are drawing. Each click 
of the Deco drawing tool on the Stage creates a grid 
of shapes. Adjust the height and width of the shapes 
by using the x and y coordinates defined by the 
Symmetry Brush handles. 


5. Click the Stage where you want the Symmetry Brush 
artwork to appear (Figure 7). 


6. Use the Symmetry Brush handles to adjust the size of 
the symmetry and the number of symbol instances. 


 
Figure 6 Advanced Options menu 


 


 
Figure 7 Placing symbols with the Symmetry 
Brush 
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The Grid Fill effect 


You can use the Grid Fill effect to fill the Stage, a symbol, or a closed region with a symbol from the library. After 
you have drawn the Grid Fill on the Stage, if you move or resize the filled symbol, the Grid Fill moves or resizes 
accordingly. 


The Grid Fill effect creates a repeating tiled background or an area or shape with a custom pattern. The default 
symbol for the Grid Fill effect is a 25-by-25-pixel black rectangular shape with no stroke. 


To apply the Grid Fill effect: 


1. Select the Deco drawing tool, and select Grid Fill from 
the Drawing Effect menu in the Property inspector 
(Figure 8). 


2. In the Property inspector, click the Edit button to select a 
custom symbol from the library. 


 The Swap Symbol dialog box appears, with a list of 
custom symbols from the library. 


 You can use any movie clip or graphics symbol in the 
library with the Grid Fill effect. 


3. Select a symbol in the Swap Symbol dialog box and 
click OK. 


4. You can use the following advanced options in the 
Property inspector to specify the horizontal and vertical 
spacing and the scale of the fill shape.  


• Horizontal Spacing: Specifies the horizontal 
distance in pixels between shapes used in the Grid 
Fill. 


• Vertical Spacing: Specifies the vertical distance in 
pixels between shapes used in the Grid Fill. 


• Pattern Scale: Enlarges or shrinks an object 
horizontally (along the x axis) and vertically (along 
the y axis). 


 Note: After you apply the Grid Fill effect, you cannot 
change the advanced options to alter the fill pattern. 


5. Click the Stage or click within the shape or symbol 
where you want the Grid Fill pattern to appear 
(Figure 9). 


 The pattern fills the area. 


 


 
Figure 8 Drawing Effect menu in the Property 
inspector 


 


 
Figure 9 Placing symbols with the Grid Fill effect 
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The Vine Fill effect 
You can use the Vine Fill effect to fill the Stage, a symbol, or a closed region with a vine pattern. You can substitute 
your own artwork for the leaves and flowers by selecting symbols from the library. The resulting pattern is 
contained in a movie clip that itself contains the symbols that make up the pattern. 


To apply the Vine Fill effect: 


1. Select the Deco drawing tool, and select Vine Fill from 
the Drawing Effect menu in the Property inspector. 


2. In the Property inspector (Figure 10), click an Edit 
button to select a custom symbol from the library if you 
want to replace the default flower and leaf symbols. 


 The Swap Symbol dialog box appears, with a list of 
custom symbols from the library. 


 You can use any movie clip or graphics symbol in the 
library to replace the default flower and leaf symbols 
when applying the Vine Fill effect. 


3. Select a symbol in the Swap Symbol dialog box and 
click OK. 


4. You can specify the horizontal and vertical spacing and 
the scale of the fill shape.  


• Branch Angle: Specifies the angle of the branch 
pattern. 


• Branch Color: Specifies the color for the branch. 


• Pattern Scale: Adjusts an object by enlarging or 
reducing it both horizontally (along the x axis), and 
vertically (along the y axis). 


• Segment Length: Specifies the length of the 
segments between leaf and flower nodes. 


• Animate Pattern: Specifies that each iteration of the 
effect is drawn to a new frame in the Timeline. This 
option creates a frame-by-frame animated sequence 
of the flower pattern as it is drawn. 


• Frame Step: Specifies how many frames to span per 
second of the effect being drawn. 


 Note: After you apply the Vine Fill effect, you cannot 
change the advanced options in the Property inspector to 
alter the fill pattern. 


5. Click the Stage or click within the shape or symbol 
where you want the Vine Fill pattern to appear 
(Figure 11). 


 The pattern fills the area. 


 


 
Figure 10 Edit buttons in the Property inspector 


 


 
Figure 11 Symmetry Brush advanced options 
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The Flash workspace 
Student name:  ________________________________________________ Date:  _______________________  


Identify the Stage, workspace, Timeline, Motion Editor, layers, panels, Tools panel, and Property inspector. 
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Identify the selection tools, the drawing tools, the view tools, and the color tools: 
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The Flash workspace 


Stage 
The Stage is the white, rectangular area of the Adobe Flash CS4 workspace (Figure 1). Objects you place on the 
Stage will appear in your published movie. Objects placed in the pasteboard (the gray area around the Stage) will 
not appear in the finished movie, but you can place objects there until you want them to appear on the Stage. 


 


 
Figure 1 Flash workspace 


 


Timeline Stage Tools panel Property inspector Motion Editor 
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Timeline and layers 
The Timeline is where you control the images and sounds in your Flash document (Figure 2). The Timeline is 
divided into frames. In the Timeline, you work with these frames to organize and control the content of your 
document. You place frames in the Timeline in the order you want the objects in the frames to appear in your 
finished content. 


A keyframe is a frame where a new symbol instance appears in the Timeline. A keyframe can also be a frame that 
includes ActionScript code to control some aspect of your document. You can also add a blank keyframe to the 
Timeline as a placeholder for symbols you plan to add later or to explicitly leave the frame blank. 


A property keyframe is a frame in which you define a change to an object’s properties for an animation. Flash can 
tween, or automatically fill in, the property values between property keyframes to produce fluid animations. Because 
property keyframes let you produce animation without drawing each individual frame, they make creating animation 
easier. A series of frames containing tweened animation is called a motion tween. 


Current frame, frame rate, and elapsed time are all shown at the bottom of the Timeline. The playhead, represented 
by a red rectangle with a long red line, shows the current frame you are viewing on the Timeline. You can click a 
frame to move the playhead to that frame, or you can drag the playhead back and forth on the Timeline to quickly 
view all or any part of your animation. 


Layers in the Timeline provide a way to organize the elements of your movie. You can draw and edit objects on one 
layer without affecting objects on another layer. Layers control the stacking order of objects—the order moves from 
top to bottom, so objects displayed in front are in the top layer, while objects displayed in back are in the bottom 
layer. This allows you to place objects in front of or behind one another. To change the order of layers, drag the 
layer name to a new position. The layer controls appear on the left side of the Timeline. Each layer has an option for 
hiding or showing the layer, locking it, and displaying its contents as outlines. 
 


 


 
 


Figure 2 Timeline 
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Edit bar 
The edit bar, at the top of the Stage, lets you quickly navigate between different parts of your Flash document 
(Figure 3). It lets you switch between scenes and symbols. You can also change the magnification level of the 
Stage.  
 


 
 


Figure 3 Edit bar 


Panels 


Panels provide easy access to controls that help you work 
with the content in your document (Figure 4). By default, 
the Property inspector and the Library panel are docked to 
the right side of the workspace. Any available panel can be 
opened by selecting it in the Window menu. 


You can undock panel groups, add panels to a group, undock 
individual panels, rearrange the order of docked panels, and 
collapse and close panel groups. To undock a panel, drag it 
by its tab or title bar away from its current position. You can 
drag it into another dock or make it free-floating. 


 
Figure 4 Panels 
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Tools panel 
The tools in the Tools panel let you draw, paint, select, and modify artwork, as well as change the view of the Stage 
(Figure 5). The Options area at the bottom of the Tools panel lets you modify a tool you have selected. If the Tools 
panel is not visible, you can display it by selecting Window > Tools. To select a tool, just click it. (You can also use 
the shortcut key shown in parentheses in the tool tip that appears when you rest the pointer over a tool for a few 
seconds.) 


 
Figure 5 Flash Tools panel 
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Selection tools 


Selection tool (black arrow): Click an object to select it. Drag a selected object to move it. 


Subselection tool (white arrow): Select and move points of an object or edit paths between adjacent points. 


Free Transform tool: Resize or rotate selected objects by dragging. Also has the Gradient Transform tool (transform 
a gradient or bitmap fill by adjusting the size, direction, or center of the fill). 


3D Rotation tool: Rotate movie clip instances in 3D space. A 3D rotation control appears on top of selected objects 
on the Stage. The X control is red, the Y control is green, and the Z control is blue.  


3D Translation tool: Move movie clip instances in 3D space. When you select a movie clip with the tool, its three 
axes, X, Y, and Z, appear on the Stage on top of the object. The X axis is red, the Y axis is green, and the Z axis is 
blue. 


Lasso tool: Drag to select an area. 


Drawing tools 


Pen tool: Create straight or curved lines. You can also create Bezier curves. 


Text tool: Create or edit text and text fields. 


Line tool: Draw straight lines. 


Rectangle tool: Create rectangles or squares composed of fills and strokes, just fills, or just strokes. Also has the 
PolyStar tool (create either polygon or star shapes—you can set how many points both shapes have), the Oval tool 
(create circles and ovals), the Rectangle Primitive tool, and the Oval Primitive tool. Primitive shapes are individual 
objects that can be edited in the Property inspector. 


Pencil tool: Create lines in any of three modes—straighten, smooth, or ink. 


Brush tool: Create shapes with fills only. 


Spray Brush tool: The Spray Brush acts like a particle sprayer, letting you “brush” a pattern of shapes onto the Stage 
at one time. By default, the Spray Brush emits a spray of dot particles using the currently selected fill color. 
However, you can use the Spray Brush tool to apply a movie clip or graphic symbol as a pattern. 


Deco Drawing tool: Apply an effect to a selected object. Choose effects from the Property inspector after you select 
the Deco Drawing tool. 


Bone tool: Inverse kinematics (IK) is a method for animating an object or set of objects in relation to each other 
using an articulated structure of bones. This tool allows you to add bones to a set of objects in relation to each other. 


Bind tool: Inverse kinematics tool that allows you to click a control point or a bone with this Bind tool and display 
the connections between the bones and control points. You can then change the connections in a variety of ways. 


Paint Bucket tool: Add fill inside a shape or change the fill color. 


Ink Bottle tool: Change the color or width of a line, or add a stroke to a shape. 


Eyedropper tool: Sample a color from swatches or anywhere on the screen. 


Eraser tool: Erase parts of an image. 


View tools 


Hand tool: Drag the Stage to view another part of your document. 


Zoom tool: Zoom in or out to view more or less of the Stage. To zoom out, hold down the Alt key (Windows) or the 
Option key (Mac OS). 


Color tools 


Stroke Color: Set the stroke color. 


Fill Color: Set the fill color. 
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Property inspector 
The Property inspector provides easy access to the most commonly used attributes of the current selection, either on 
the Stage or in the Timeline. You can make changes to the object or document attributes in the Property inspector 
without accessing the menus or panels that also control these attributes. 


Depending on what is currently selected, the Property inspector displays information and settings for the current 
document, text, symbol, shape, bitmap, video, group, frame, or tool. When two or more different types of objects are 
selected, the Property inspector displays the total number of objects selected. By default, the Property inspector is 
visible; you can hide or show it by selecting Window > Properties. Figure 6 shows the properties for a text object 
and a rectangle shape, respectively. 


     
Figure 6 Property inspector for text (left) and for rectangle (right) 
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Frames and keyframes 
Like films, Adobe Flash CS4 Professional documents divide lengths of time into frames. In the Timeline, you work 
with these frames to organize and control the content of your document. You place frames in the Timeline in the 
order you want the objects in the frames to appear in your finished content.  


Frames define increments on the Timeline (Figure 1). The order in which frames appear on the Timeline determines 
the order in which they appear when a Flash document plays. You can arrange keyframes on the Timeline to edit the 
sequence of events in an animation. 


A keyframe is a frame where a new symbol instance appears in the Timeline. A keyframe can also be a frame that 
includes ActionScript code to control some aspect of your document. You can also add a blank keyframe to the 
Timeline as a placeholder for symbols you plan to add later or to explicitly leave the frame blank. 


A property keyframe is a frame in which you define a change to an object’s properties for an animation. Flash can 
tween, or automatically fill in, the property values between the property keyframes in order to produce fluid 
animations. Because property keyframes let you produce animation without drawing each individual frame, they 
make creating animation easier. A series of frames containing tweened animation is called a motion tween. 


A tweened frame is any frame that is part of a tween. 


A static frame is any frame that is not part of a tween. 


You arrange keyframes and property keyframes in the Timeline to control the sequence of events in your document 
and its animation. 


A keyframe is indicated on the Timeline with a solid black circle. The frame where a keyframe span ends has a 
small white rectangle. A blank keyframe is indicated by an empty circle. 


 
 


Figure 1 Frames 


You can do the following with frames or keyframes: 


• Insert frames, keyframes, and blank keyframes. 


• Remove frames, keyframes, and blank keyframes. 


• Convert frames to keyframes or blank keyframes. 


• Drag frames and keyframes to a new location on the same layer or on a different layer. 


• Copy and paste frames and keyframes. 


static 
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Representing animations in the Timeline 
Flash distinguishes tweened animation from frame-by-frame animation in the Timeline by displaying different 
indicators in each frame that contains content. The following frame content indicators appear in the Timeline: 


• A span of frames with a blue background indicates a motion tween. A black dot in the first frame of the span 
indicates that the tween span has a target object assigned to it. Black diamonds indicate the last frame and any 
other property keyframes. Property keyframes are frames that contain property changes explicitly defined by 
you. To choose which types of property keyframes to display, right-click (Windows) or Command-click (Mac 
OS) the motion tween span, and choose View Keyframes > type from the context menu. Flash displays all types 
of property keyframes by default. All other frames in the span contain interpolated values for the tweened 
properties of the target object.  


 
• A hollow dot in the first frame indicates that the target object of the motion tween has been removed. The tween 


span still contains its property keyframes and can have a new target object applied to it. 


 
• A span of frames with a green background indicates an inverse kinematics (IK) pose layer. Pose layers contain 


IK armatures and poses. Each pose appears in the Timeline as a black diamond. Flash interpolates the positions 
of the armature in the frames between poses. 


 
• A black dot at the beginning keyframe, with a black arrow and blue background, indicates a classic tween. 


 
• A dashed line indicates that the classic tween is broken or incomplete, such as when the final keyframe is 


missing. 


 
• A black dot at the beginning keyframe with a black arrow and a light green background indicates a shape tween. 


 
• A black dot indicates a single keyframe. Light gray frames after a single keyframe contain the same content 


with no changes. These frames have a vertical black line and a hollow rectangle at the last frame of the span. 


 
• A small a indicates that the frame is assigned a frame action with the Actions panel.  


 
• A red flag indicates that the frame contains a label. 


 
• A green double slash indicates that the frame contains a comment. 


 
• A gold anchor indicates that the frame is a named anchor. 
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Creating animation in Adobe Flash CS4 


Overview of tweening 
A tween is an animation you create by specifying a value for an object property in one frame and another value for 
that same property in another frame. Adobe Flash calculates the values for that property between those two frames. 
The term tween comes from the phrase in between. You can tween movie clip, graphic, and button symbols and text 
fields. 


A tween span is a group of frames in the Timeline in which an object on the Stage can have one or more properties 
changed over time. A tween span appears in the Timeline as a group of frames in a single layer with a blue or green 
background. You can select a tween span as a single object and drag it from one location in the Timeline to another, 
including to another layer. Only one object on the Stage can be animated in each tween span. This object is called 
the target object of the tween span. 


A property keyframe is a frame within a tween span where you explicitly define one or more property values for the 
tween target object. Each property you define has its own property keyframes. If you set more than one property in a 
single frame, the property keyframes for each of those properties reside in that frame. You can view each property of 
a tween span and its property keyframes in the Motion Editor. You can also choose which types of property 
keyframes to display in the Timeline from the tween span context menu. 


Note: Beginning with Adobe Flash Professional CS4, the concepts of keyframe and property keyframe differ from 
earlier versions of Flash. The term keyframe refers to a frame in the Timeline in which a symbol instance appears on 
the Stage for the first time. The term property keyframe, new to Flash CS4, refers to a value defined for a property at 
a specific time or frame in a motion tween. 


Types of Flash CS4 Animation 
Motion tweens: Set properties for an object, such as position and alpha transparency in one frame and again in 
another frame, and Flash interpolates the property values of the frames in between. Motion tweens are useful for 
animation that consists of continuous motion or transformation of an object. Motion tweens appear in the Timeline 
as a contiguous span of frames you can select as a single object by default. Motion tweens are powerful and simple 
to create. 


Shape tweening: Draw a shape at one frame in the Timeline and change that shape or draw another shape at another 
frame. Flash then interpolates the intermediate shapes for the frames in between, creating the animation of one shape 
morphing into another. 


Classic tweens: Like motion tweens but more complex to create. You can create some specific animated effects not 
possible with span-based tweens. For example, you can apply eases to the groups of frames between the keyframes 
within the tween instead of across the entire length of a motion tween span. (To ease only specific frames of a 
motion tween, you must create a custom ease curve.) You can also use classic tweens to animate between two color 
effects, such as tint and alpha transparency, while motion tweens can apply only one color effect per tween. 


Inverse kinematic poses: You can stretch and bend shape objects and link groups of symbol instances to make them 
move together in naturalistic ways. If you position the shape object or linked instances in different ways in separate 
frames, Flash interpolates the positions in the frames in between. Inverse kinematics poses help make character 
animation quick and easy. 


Note: You will learn more about how to use inverse kinematics poses to create character animations in Activity 5.4. 


Motion tweens 
You apply motion tweens only to symbol instances and text fields. All other object types are wrapped in a symbol 
when a tween is applied to them. The symbol instance can contain nested symbols, which can themselves be 
tweened on their own timelines. 
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The minimal building block in a tween layer is a tween span, which can contain only one symbol instance. The 
symbol instance is called the target instance of the tween span. If you add a second symbol to the tween span, the 
new symbol replaces the original one. You can change the target object of a tween by dragging a different symbol 
from the library onto the tween span in the Timeline. You can delete the symbol from a tween layer without 
removing or breaking the tween. 


To have a symbol in the Timeline, you do not have to include more than one property keyframe. You can edit 
individual property keyframes on the Stage, in the Property inspector, or in the Motion Editor. 


To create a motion tween: 


1. Start Flash and open a new blank document. 


2. Draw a shape on the Stage. 


 The shape appears in keyframe 1 of Layer 1. 


3. Using the Selection Tool (Figure 1), select the shape 
and choose Modify > Convert To Symbol. Double-click 
to select the shape and border, if present.  


 The Convert To Symbol dialog box appears (Figure 2). 


 Note: You cannot apply motion tweens to shapes. 
Applying a motion tween to a shape automatically 
converts the shape to a symbol. 


4. Type a new name for the symbol in the Name text box, 
select the Graphic option, and click OK (Figure 2). 


5. Select frame 10. 


6. Select Insert > Timeline > Frame. (The motion tween 
will last for 10 frames.) 


 When you insert a frame, Flash fills the area between the 
last frame (on the current layer) and the new frame with 
the same content (Figure 3). Frames 1 through 10 all 
contain the new symbol. 


7. Make sure frame 10 (the end frame for the motion 
tween) is selected and select Insert > Motion Tween. 


8. Select the symbol in frame 10; then make one or more of 
the following changes: 


 Color change: In the Property inspector, select Tint 
from the Color Effect Style pop-up menu (Figure 4). 
Select 100% for the Tint Amount and change the color 
in the color box. 


 Fading: In the Property inspector, select Alpha from the 
Color Effect Style pop-up menu. Reduce the percentage 
of the Alpha Amount for more transparency. For 
example, an Alpha value of 0% makes the object 
disappear. 


 Position: Use the Selection tool to move the object to a 
different position on the Stage. A motion path appears. 
The points on this motion path are editable. 


 
Figure 1 Flash toolbars with Selection tool 


 


 
Figure 2 Convert To Symbol dialog box 


 


 
Figure 3 Inserted keyframe 


 


 
Figure 4 Color pop-up menu 


 


Selection tool 
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 Size: Select the object. Then select Modify > 
Transform > Free Transform. Drag the object handles to 
increase size, decrease size, and rotate the object. 


9. Select frame 1 on the Timeline. 


 In the Timeline, the motion tween is represented by a 
solid blue background running from the start keyframe 
to the end keyframe (Figure 5). 


10. With the Timeline selected, (Figure 6), adjust one or 
more properties of the Motion tween from the Properties 
panel. 


• Ease: Controls how fast the object starts or ends the 
motion tween. For example, a high number makes 
an object begin tweening quickly and end slowly. 


• Rotate: Rotates the object clockwise or 
counterclockwise a designated number of times. 


• Path: If you add a guide layer, the object is linked 
to the path drawn on the guide layer. 


• Options: Starts and stops the tweening of all objects 
on the Stage at the same time. 


11. You can also use the Motion Editor to adjust tweens 
(Figure 7). 


 You can view all tween properties and their property 
keyframes in the Motion Editor. You can also add 
precision and detail to your tweens. Once you create a 
tween in the Timeline, you can control the tween in 
several different ways:  


• Add or remove property keyframes for individual 
properties. 


• Move property keyframes to different frames within 
the tween. 


• Add or remove filters or color effects and adjust 
their settings. 


• Add different preset eases to individual properties 
and property categories. 


• Create custom ease curves. 


• Enable roving for individual property keyframes for 
X, Y, and Z properties. Roving allows the property 
keyframe to move to different frames or between 
individual frames to create smooth motion. 


 
Figure 5 Motion tween in the Timeline 


 


 
Figure 6 Tween Property inspector 


 


 
Figure 7 Motion Editor 







Activity 5.1 guide Adobe Flash CS4  


4 Creating animation in Adobe Flash CS4 © 2008 Adobe Systems Incorporated 


12. Select Control > Test Movie to test the movie. 


13. Select File > Close to close the preview window. 


14. To see all phases of the tween at the same time, click the 
Onion Skin Outline button at the bottom of the Timeline 
(Figure 8). 


15. Drag the onion skinning frame handles (they appear as 
brackets with circles on them at the top of the Timeline) 
to span the frames in which the object appears. 


 The steps of the tween are all visible on the Stage 
(Figure 9). 


16. Turn off onion skinning. 


17. Save the movie. 


 
 


Figure 8 Onion Skin Outline button 


 


 
Figure 9 Onion skinning visible 


Shape tweens 
In shape tweening, you draw a vector shape at one specific frame in the Timeline and change that shape or draw 
another shape at another specific frame. Flash then interpolates the intermediate shapes for the frames in between, 
creating the animation of one shape morphing into another. 


Note: Shape tweens work best with simple shapes. Avoid shapes with cutouts or negative spaces in them. 
Experiment with the shapes you want to use to determine the results. You can use shape hints to tell Flash which 
points on the beginning shape should correspond to specific points on the end shape. Shape tweens can use much 
more computer memory than motion tweens, so it is best to use shape tweens sparingly. 


Onion Skin Outline 
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To create a shape tween: 


1. Start Flash and open a new blank document. 


 Frame 1 in Layer 1 already contains a blank keyframe. 


2. Begin by adding a shape to the Stage: 


 Drawn objects: Select a shape tool (rectangle or oval) 
and draw an object on the Stage. 


 Text: Select the Text tool and type a word or phrase on 
the Stage. Then select the text and select Modify > 
Break Apart. This breaks the words into separate letters. 
With the letters still selected, select Modify > 
Break Apart again to convert the letters into shapes. 


 Outside images: Select File > Import > Import To Stage 
to import an image. If the image is a bitmap, you must 
break it apart. If the image is a grouped vector drawing, 
you must ungroup it completely. To break apart a 
bitmap, select Modify > Break Apart. To ungroup an 
image, select Modify > Ungroup. 


 Note: You might need to select Modify > Break Apart 
or Modify > Ungroup multiple times until the object 
becomes a shape, as indicated in the Property inspector. 


3. Select frame 10. 


4. Select Insert > Timeline > Keyframe. 


 The tween will last for 10 frames. 


5. Make sure frame 10 is still selected and make one or 
more of the following changes to your shape: 


 Amorphous shape change: Click the Stage with the 
Selection tool to deselect the object. Bring the Selection 
tool close to the object to grab an edge. Drag the edge to 
change the shape of the object (Figure 10). 


 Different shape: To morph between your original shape 
and a new shape, delete the object in keyframe 10 and 
draw a new object. 


Note: Select Modify > Break Apart if the drawn object 
is not a shape. 


 Text: To morph between your original shape and some 
text, delete the object in keyframe 10 and type the text 
on the Stage. Select Modify > Break Apart until the text 
block is a shape, as indicated in the Property inspector. 


 Outside image: To morph between your original shape 
and a new image you import, delete the object in 
keyframe 10 and select File > Import to bring in the 
outside image. Select Modify > Break Apart to make the 
object a shape,  as indicated in the Property inspector. 


 
Figure 10 Changing a shape with the Selection 
tool 
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6. Click anywhere inside the tween span on the Timeline 
(Figure 11) and select Insert > Shape Tween. 


7. Select frame 1 on the Timeline (on the current layer). 


 This is the start frame for your animation. 


8. In the Tweening section of the Property inspector, adjust 
one or more properties of the Shape tween (Figure 12): 


 Ease: Controls how fast the object starts or ends the 
shape tween. For example, a high number begins the 
tweening quickly and ends slowly. 


 Blend (Distributive): Creates an animation in which the 
intermediate shapes are smoother and more irregular. 


 Blend (Angular): Creates an animation that preserves 
corners and straight lines in the intermediate shapes. 


9. Select Control > Test Movie to test the movie. 


10. Select File > Close to close the preview window. 


11. To see all phases of the tween at the same time, click the 
Onion Skin button at the bottom of the Timeline. 


12. Drag the frame handles (they appear as brackets with 
circles on them at the top of the Timeline) to span the 
first 10 frames of Layer 1. 


 The steps of the tween are all visible on the Stage. 


13. Turn off onion skinning. 


14. Save the movie. 


15. Close the movie. 


 
Figure 11 Click inside the tween span 


 


 
Figure 12 Tweening in the Property inspector 


Classic tweens 
In classic tween animation, you define keyframes at significant points in the animation and Flash creates the 
contents of frames between. The interpolated frames of a tweened animation appear as light blue with an arrow 
drawn between keyframes. Because Flash documents save the shapes in each keyframe, create keyframes only at 
those points in the artwork where something changes. 


Classic tweens are similar to motion tweens, except they are more complex and you can create certain types of 
animated effects not possible with motion tweens, such as 


• Work with Timeline effects 


• Add an animation to instances, groups, or types 


• Create tween motion along a path 


• Paste motion tween properties 


• Apply custom ease-in/ease-out settings 


Note: Advanced uses of classic tweens, such as those listed here, will be dealt with in greater detail in Unit 6. The 
following exercise outlines the steps for creating a simple classic tween, which serves as a basic introduction to 
classic tweening and the procedural differences between classic and motion tweening. 
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To create a classic tween: 


1. Start Flash and open a new blank document. 


 Frame 1 in Layer 1 already contains a blank keyframe. 


2. Begin by adding a symbol to the Stage. 


3. Select frame 10. 


4. Select Insert > Timeline > Keyframe. 


 The tween will last for 10 frames (Figure 12). 


5. Make sure frame 10 is still selected and move the 
symbol to a new position on the Stage. 


6. Click on the tween span on the Timeline and select 
Insert > Classic Tween.  


 The classic tween appears as light blue with an arrow 
(Figure 13). 


7. Select frame 1 on the Timeline (on the current layer). 


 This is the start frame for the animation. 


8. Adjust the position, color, or scale of the symbol in the 
starting keyframe. 


9. Select frame 10, and adjust the position, color, or scale 
of the symbol to be as you want the animation to end. 


 You can also adjust the properties of the symbol in the 
tweening section of the Property inspector. 


10. Select Control > Test Movie to test the movie. 


11. Select File > Close to close the preview window. 


12. Save the movie. 


13. Close the movie. 


 


 
Figure 12 Insert keyframe 


 


 
Figure 13 Insert classic tween 
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How to ease tweens 
Easing is a technique for modifying the way Flash calculates the property values between property keyframes in a 
tween. Without easing, Flash calculates these values so the change to the value is the same in each frame. You can 
use easing to adjust the rate of change to the values for more natural or more complex animation. 


An ease is a mathematical curve you apply to the property values of a tween. The final effect of the tween is the 
result of the combination of the range of property values in the tween and the ease curve. 


You can apply easing in the Motion Editor for motion tweens or in the Property inspector for classic tweens. Eases 
applied in the Motion Editor can affect a single property, a group of properties, or all properties of a tween. Eases 
applied in the Property inspector affect a single property or all of the properties included in a tween. 


An ease can be simple or complex. Flash includes a range of preset eases you can apply for simple or complex 
effects. In the Property inspector or Motion Editor, you can also create your own custom ease curves. 


One of the many common uses of easing is when you have edited a motion path on the Stage and enabled roving 
keyframes to make the speed of motion consistent in each segment of the path. You can then use easing to add more 
realistic acceleration and deceleration at the ends of the path. 


Easing individual properties for motion tweens in the Motion Editor 
You can apply a preset ease to an individual property or a category of properties in the Motion Editor. 


To apply a preset ease: 


1. Start Flash. Open a document containing a motion tween. 


2. In the Timeline, select the motion tween and select the 
Motion Editor tab (Figure 1). 


3. In the Motion Editor, add the ease to the list of eases 
available to the selected tween, and then apply the ease 
to the properties you choose (Figure 2). (See the 
following bullet points for instructions.) 


 


 
 


Figure 1 Flash Timeline with motion tween and 
Motion Editor tab 
 


 
Figure 2 Adding eases in the Motion Editor 
 


 


 


 


Motion Editor tab 
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 When you apply the ease to a property, you can see its 
curve on the graph area of the property curve (Figure 3). 


• To add an ease to the list of eases for the selected 
tween, click the Add button in the Ease section at 
the bottom of the Motion Editor, and then select the 
ease to add. 


• To add an ease to a single property, select the ease 
from the Selected Ease menu for the property. 


• To add an ease to a whole category of properties, 
such as motion, transformation, color effect, or 
filters, select an ease type from the Selected Ease 
menu for the property category. 


• To enable or disable the effect of an ease for a 
property or category of properties, select the 
Enable/Disable Ease option for the property or 
category of properties. This allows you to quickly 
see the effect of an ease on property curves. 


• To remove an ease from the list of available tweens, 
click the Remove Ease button in the Eases section of 
the Motion Editor and then select the ease from the 
pop-up menu. 


4. To preview the animation on the Stage, click Enter 
(Windows) or Return (Mac OS). 


5. Adjust the eases in the tween until you achieve the 
desired effect.  


 


 
Figure 3 Bounce In ease added to Motion Editor 


Editing ease curves for motion tweens in the Motion Editor 
In the Motion Editor, you can edit the shape of preset ease curves and create custom ease curves. 


• To edit a preset ease curve, set the value for the ease in 
the field next to the ease name (Figure 4). 


• For simple ease curves, the value is a percentage 
representing the strength of the application of the 
ease curve to the property curve. Positive values 
increase the ease at the end of the curve. Negative 
values increase the ease at the beginning of the 
curve. 


• For ease curves that are waves, such as the sine 
wave or sawtooth wave, the value represents the 
number of half-cycles in the wave. 


• To edit a preset ease, first add it to the list of 
available eases by using the Add button in the Ease 
section of the Motion Editor. 


• To edit a custom ease curve, add it to the list of 
eases and then edit the curve by using the same 
techniques for editing any other Bezier curve. 


 


 
Figure 4 Editing a simple ease curve 
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Easing individual properties for classic tweens in the Property inspector  
You can create eases for classic tweens by using the Property inspector. 


To ease a classic tween: 


1. Start Flash and open a document containing a classic 
tween. 


2. In the Timeline, select the classic tween (Figure 5). 


3. In the Property inspector, enter a value for the strength 
of the ease in the Ease Value field (Figure 6). 


4. To preview the animation on the Stage, click Enter 
(Windows) or Return (Mac OS). 


5. Adjust the eases in the tween until you achieve the 
desired effect.  


 


 


 
Figure 5 Classic tween in the Timeline 


 


 
Figure 6 Editing a simple ease curve 


 


Ease Value field 
  


   


Edit button 
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Editing ease curves for classic tweens in the Property inspector  
In the Property inspector, you can edit the shape of the curves to create custom ease-ins and ease-outs. 


To edit ease curves: 


1. In the Timeline, select the classic tween that you wish to 
change the ease curves.  


2. Click the Edit button next to the Ease Value field in the 
frame Property inspector (Figure 6).  


 The Custom Ease In/Ease Out dialog box appears 
(Figure 7). 


3. (Optional) To display the curve for a property, deselect 
Use One Setting For All Properties, and select a 
property in the menu (Figure 8). 


4. You can add control points anywhere along the curve to 
help you manipulate the curve. To add a control point, 
Control-click (Windows) or Command-click (Mac OS) 
the diagonal line. 


5. To increase the speed of the object, drag the control 
point up; to slow down the speed of the object, drag it 
down. 


6. To further adjust the ease curve and fine-tune the ease 
value of the tween, drag the vertex handles (Figure 9). 


7. To view the animation on the Stage, click the play 
button in the lower left corner. 


8. Adjust the controls until you achieve the desired effect. 


 Note: If you use the Custom Ease In/Ease Out dialog 
box to apply a custom ease to a frame, the ease value 
edit box displays '--'. If you use the edit box or the 
pop-up slider to apply an ease value to a frame, the 
Custom Ease graph is set to the equivalent curve, and 
the Use One Setting For All Properties option is 
selected. 


 


 


 


 
Figure 7 Custom Ease In / Ease Out dialog box 


 


 
Figure 8 Easing property menu 


 


 
 


Figure 9 Vertex handles and play button 
 
 


Play button Vertex handles 
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How to create masks 
In Adobe Flash CS4, a mask is a special type of layer that lets you reveal select parts of another layer. For example, 
if you want to show people walking around inside a house, and you want them to be visible when they pass by a 
window but invisible otherwise, you can use a mask. You can use masking for techniques such as creating a 
spotlight or showing pictures behind images. 


Creating a mask 


1. Start Flash and open a document. 


2. Import an image to the Stage. 


3. Create a new layer and name it mask. Put this layer 
directly above the layer containing the image. 


2. Use a drawing tool, such as the Oval tool or the 
Rectangle tool, to define the area of the mask layer that 
you want to be transparent (Figure 1).  


 Make the transparent area of the mask a solid, noticeable 
color. This will help you see where the transparent area 
is. 


4. Right-click (Windows) or Control-click (Mac OS) the 
mask layer, and select Mask from the pop-up menu. 


 The two layers change to indicate that the bottom layer 
is masked. The name of the masked layer is indented 
under the name of the masking layer and its icon 
changes to a mask layer icon (Figure 2). 


 Note: To display the mask effect, lock both the mask 
layer and the layer containing the masking content. 
Unlock one or both layers to hide the effect. 


5. Select Control > Test Movie to see it play. 


 Observe that only the masked area is visible. 


6. Select File > Close to close the preview window. 


 


 
 


Figure 1 Mask layer with mask area 


 


 
 


Figure 2 Mask applied 


Mask area Mask layer 


Lock icon Mask icon 
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Animating the mask 


You can animate the mask so that, for example, the mask pans along a picture. 


7. On the mask layer, add a frame at frame 20. 


8. On the masked layer below, also add a frame at frame 
20. 


9. Click the Mask layer anywhere between frames 1 and 
20, and then select Insert > Motion Tween. 


10. Unlock the mask layer, click frame 20, and move the 
mask object (Figure 3).  


11. Adjust the motion guide as necessary. 


12. Select Control > Test Movie to see it play. 


 Observe that only the masked area moves across the 
content beneath it. 


13. Select File > Close to close the preview window.  
Figure 3 Motion tween on the mask layer 


Change the masked content 


You can change content on the layer below the mask while keeping the mask the same. 


14. On the masked layer, select frame 10 and select Insert > 
Timeline > Blank Keyframe. 


 Inserting a blank keyframe clears the contents of the 
frame. 


 The contents of the masked layer clear. 


15. Add new content to the masked layer at frame 10. 


 For example, you could drag a different picture to the 
Stage. 


16. Select Control > Test Movie to see it play. 


 Observe that the area under the mask changes halfway 
through the animation. 


17. Select File > Close to close the preview window. 


 


Reverting the masked content to its original state 


18. Select frame 10 (where you inserted the second 
keyframe), and select Modify > Timeline > 
Clear Keyframe. 


 This reverts the keyframe to a regular frame, and 
changes the layer back to its original state. 
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How to import sound 
In Adobe Flash CS4, you can import sound and video to integrate them into the Timeline. You can create media-rich 
content with very precise control. 


Importing sound 
You can use sound for many purposes in Flash. Some examples include soundtracks, narration, and sound effects 
that complement objects such as rollover buttons. 


You can import the following sound file formats into Flash: 


• ASND Adobe Sound Document 


• WAV (Windows only) 


• AIFF (Mac OS only) 


• MP3 (Windows or Mac OS) 


If you have QuickTime 4 or later installed on your system, you can import these additional sound file formats: 


• AIFF (Windows or Mac OS) 


• Sound Designer II (Mac OS only) 


• Sound Only QuickTime Movies (Windows or Mac OS) 


• Sun AU (Windows or Mac OS) 


• System 7 Sounds (Mac OS only) 


• WAV (Windows or Mac OS) 


When you import a sound file, it’s placed in the library. Then you can drag an instance (copy) of the sound onto the 
Stage. Sound files must be tied to keyframes. 


You can synchronize a sound to your movie in several ways (using the Sync pop-up menu in the Property inspector): 


• Event: An event sound plays when the playhead reaches the first keyframe containing the sound. It plays in 
its entirety, independent of the Timeline, even if the movie stops. If a different instance of the same sound 
is started, the sounds will overlap. 


• Start: The same as Event, except that if the sound is already playing, no new instance of the sound will 
begin playing. 


• Stop: Silences the specified sound. 


• Stream: Forces the movie to keep pace with the sound. If Flash can’t draw animation frames quickly 
enough, it skips frames. Unlike event sounds, stream sounds stop if the movie stops. Stream sounds can 
also produce a much smaller file size, although their quality tends to be poorer than event sounds. 
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Import a sound 


1. Start Flash and open a document. 


2. Insert a new layer. 


3. Double-click the new layer name, and rename it Sound. 


4. Select File > Import > Import To Library. 


 The Import dialog box opens (Figure 1). 


5. Locate a sound file, select it, and click Open (Windows) 
or Import To Library (Mac OS). 


 Note: You can download free music loops and sound 
effect clips at www.flashkit.com, for example. 


6. Select frame 1 on the Sound layer. 


7. Make sure the Library panel is open. (If not, select 
Window > Library.) 


 The sound appears in the Library panel. To preview the 
sound, select it and then click the Play button in the 
preview (upper) pane of the Library panel (Figure 2). 


8. Drag the sound file from the Library panel onto the 
Stage. 


 Note: The Sound layer must contain enough frames to 
play the entire sound. For example, if your movie is set 
for 12 frames per second and your sound is 2 seconds 
long, the Sound layer must contain at least 24 frames. If 
you are adding sound to an existing movie, your movie 
might already be long enough to accommodate the 
sound. 


9. If necessary, add frames to the Sound layer. To do this, 
click a frame down the Timeline for the Sound layer, 
such as frame 24 for a 2-second movie at 12 fps, and 
select Insert > Frame. 


 The sound does not appear on the Stage but does appear 
on the Timeline as a waveform (Figure 3).  


 Note: Press the F5 key to insert a frame. Press Shift-F5 
to delete a frame. 


 
Figure 1 Import dialog box 


 


 
Figure 2 Library panel 


 


 
Figure 3 Sound in Timeline 


Play button 
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Editing sound settings 
Through the Property inspector, you can change settings for the sound, including making the sound fade in and fade 
out. 


10. Select the first keyframe and adjust the settings for the 
sound in the Property inspector (Figure 4). 


 Effect: Choose from previously created effects such as 
Fade In, Fade Out, keeping sound in only one channel 
(left or right), or fading sound from one channel to the 
other (Figure 5). Choosing Custom (or clicking the Edit 
button) opens a sound-editing window where you can 
create your own fading effects (Figure 6). In the sound-
editing window, called the Edit Envelope dialog box, 
adjust the sound handles to control sound volume in 
each channel. 


 Sync: Choose Event, Start, Stop, or Stream. 


 Loop: Set the number of times to have the sound replay. 


 
Figure 4 Sound Property inspector 


 


 
Figure 5 Effect pop-up menu 


 


 
Figure 6 Edit Envelope dialog box 







Activity 5.3 guide Adobe Flash CS4  


4 How to import sound © 2008 Adobe Systems Incorporated 


Sound compression 
Sound files can drastically increase the file size of your movies. One way to control this is to set the compression for 
the sounds in Flash. 


1. Make sure the Library panel is open, and select the 
sound file. 


2. Click the Properties button in the Library panel 
(Figure 7). 


 The Sound Properties dialog box opens (Figure 8). 


3. Choose a compression method from the Compression 
menu and click OK. 


 ADPCM: This method sets the compression for 8-bit 
and 16-bit sound data. Use this when you export short 
event sounds such as button clicks. 


 MP3: This method offers good compression and sound 
fidelity for longer stream sounds such as music tracks. 


 Raw: This resamples the file but does not perform any 
compression. 


 Speech: A good compression to use for speech sound 
files. 


4. Save the movie. 


5. Select Control > Test Movie. 


 
Figure 7 Library Properties button 


 


 
Figure 8 Sound Properties dialog box 


 


Properties button 
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How to create a button symbol 


Button symbols 
Buttons give visitors a way to control parts of a movie. You can use button symbols to create interactive buttons that 
respond to mouse clicks, rollovers, or other visitor interaction. Button symbols are four-frame interactive movie 
clips. The first three frames display the button’s three possible states: Up, Over, and Down. The fourth frame, Hit, 
defines the active area of the button. The Timeline for a button doesn’t play like other movies; it reacts to pointer 
movement and actions by jumping to and displaying the appropriate frame. 


You can create the image that represents your buttons in several ways. For example, you can use an existing graphic 
as the button, or you can create a shape by using the drawing tools. 


Create a button 
You will create a new button symbol that contains two layers. One layer will contain a shape representing the 
background of the button. The second layer will include a text label for the button. You will change the background 
and text label in the Over and Down states of the button to create the rollover effect. 


1. Start Adobe Flash CS4 and create a new Flash file 
(ActionScript 3.0). 


2. Select Insert > New Symbol. 


 The Create New Symbol dialog box appears (Figure 1). 


3. Select Button as the behavior type, name the button, and 
click OK. 


 You are now in symbol-editing mode and viewing a 
separate Timeline for the button symbol. The Up frame 
contains a keyframe (Figure 2). 


 Each frame on the Timeline of a button symbol has a 
specific function: 


• Up state: Represents the button’s appearance 
whenever the pointer is not over the button. 


• Over state: Represents the button’s appearance 
when the pointer is over it. 


• Down state: Represents the button’s appearance as 
it is clicked. 


• Hit state: Defines the area that will respond to a 
mouse click. This area will be invisible in the 
published movie. 


4. Make sure the Up frame is selected. 


5. Use the drawing tools to create a shape for your button. 
Use the Property inspector to set the fill and stroke 
colors for the Up state of the button. 


6. Select the Over state and select Insert > Timeline > 
Keyframe to add a keyframe. 


 Adding this keyframe copies the button graphic from the 
Up frame to the Over frame. 


 
Figure 1 Create New Symbol dialog box 


 


 
Figure 2 Button frames: Up, Over, Down, Hit 
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7. Select the Over keyframe and use the Selection tool to 
select the button. 


8. Change the fill or stroke color of the button shape. 


 When visitors roll over the button, the button will appear 
as you see it in the Over frame. 


9. Insert keyframes in the Down and Hit frames of the Text 
layer. 


 This copies the button graphic from the Over frame to 
the Down and Hit frames. 


10. Insert a new layer and name it Text. 


11. Select the Up frame of the Text layer. 


 This frame already contains a keyframe. 


12. Use the Text tool to type text on the button shape. 


13. Use the Property inspector to adjust the font, size, and 
color of the text so it fits nicely on your button shape. 


14. Use the Selection tool or the Up, Down, Left, and Right 
Arrow keys to position the text on the button shape. 


15. Insert a keyframe in the Over frame of the Text layer. 


16. Select the text and use the Property inspector to change 
some feature of the text in the Over frame, such as color. 


17. Insert a keyframe in the Down frame. If you want the 
text to change appearance when the button is clicked, 
edit the appearance of the text in the Down frame. 


 The Timeline should now appear as it does in Figure 3. 


 Now you can insert an instance (copy) of the button 
symbol into the main Timeline of your movie. 


18. Click Scene 1 to exit symbol-editing mode and return to 
the main Timeline. 


19. Select Window > Library to display the Library panel. 


 The new button symbol appears in the Library panel 
(Figure 4). 


 Note: You must select the symbol in the library to see 
the symbol in the preview pane. 


20. Drag the button symbol from the library onto the Stage. 


21. Select Control > Test Movie to test the movie. 


 When you roll over the button with the pointer, you see 
the changes you defined in the Over frames for the 
button. If you edited the Down state of the button, this 
will be visible when you click the button. 


22. Select File > Close to close the preview window. Then 
save your movie. 


 
Figure 3 Button Timeline 


 


 
Figure 4 Button in library 
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Adding sound to a button 


You can also add sounds to the button so visitors hear a sound when they interact with the button. 


1. Use the Selection tool to double-click the button to enter 
symbol-editing mode for the button. 


2. Insert a new layer and name it Sound. 


3. Select File > Import > Import To Library to import a 
short sound into the library.  


 You can acquire royalty-free sounds from sites such as 
www.flashkit.com. 


4. On the Sound layer, add a keyframe to correspond with 
the button state to which you want to add a sound. 


 For example, to play a sound when visitors roll over the 
button, add the keyframe to the Over state. 


5. Click the new keyframe. 


6. Make sure the Property inspector is visible. (Select 
Window > Properties.) 


7. In the Property inspector, select a sound file from the 
Sound pop-up menu (Figure 5). 


8. Select Event in the Sync pop-up menu. 


 The sound will play when visitors interact with the 
button. 


 
 


Figure 5 Property inspector 


 


Sound pop-up menu 
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Adding control with actions 


Right now the button looks great, but it doesn’t perform any action. You can remedy this by adding ActionScript 
code to your movie. 


Buttons give visitors control over the movie. You can create code for your buttons to stop the movie, stop sounds, 
restart the movie (after stopping it), or jump to different frames within the movie and begin playing. You can add 
actions to any instance of the button symbol you’ve placed in your movie. 


1. Select the button instance to which you want to add an 
action. Use the Name text box in the Property inspector 
to give the button a unique instance name (Figure 6). 


2. In the main timeline of your movie, create a new layer 
named Actions. 


3. Create a keyframe in the actions layer that corresponds 
to the keyframe where your button first appears on the 
Stage. Select this keyframe in the actions layer. 


 Note: If your button doesn’t appear on this frame, Flash 
generates an error message when you publish the movie 
because the ActionScript you include on this frame 
refers to an object that isn’t on the Stage yet. 


4. Select Window > Actions to display the Actions panel. 


5. If you don’t see the parameters area in the Actions 
panel, click the Script Assist button. 


6. In the Actions toolbox on the left side of the panel, 
select the AddEventListener method for the 
IEventDispatcher class. 


 To find the AddEventListener method, expand 
Flash.Events, and then expand IEventDispatcher. 


7. Double-click the AddEventListener method to add it to 
the Script pane (Figure 7). 


8. Click in the Object field in the parameters area of the 
Actions panel. 


 The Insert Target Path button is now active. 


9. Click the Insert Target Path button. 


 The Insert Target Path dialog box appears (Figure 8). 


10. Select the Relative option and select the instance name 
of your button. Click OK to close the dialog box. 


 
 


Figure 6 Button Property inspector 


 


 
Figure 7 AddEventListener method in the Actions 
toolbox 


 


 
Figure 8 Insert Target Path dialog box 


Instance name 
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11. In the Actions toolbox on the left side of the panel, 
select the CLICK property from the MouseEvent class 
(Figure 9). 


 To find the CLICK property, expand Flash.Events, and 
then expand MouseEvent. 


12. In the Script pane, select the AddEventListener() line to 
display the parameters for this method. Then, in the 
parameters area, click in the Type field. 


13. In the Actions toolbox, double-click the CLICK 
property. 


 Script Assist adds the property to your code as 
MouseEvent.CLICK (Figure 10). 


14. In the Listener field in the parameters area, type a name 
for the function that should execute when the button is 
clicked. You can use any name you like, but make sure 
the name of the function is unique and contains no 
spaces. 


 The function name appears in the Script pane as you 
type. You have named the function, but you haven’t 
created it yet. 


15. In the Actions toolbox, select the function keyword 
from Language Elements.  


 To find the function keyword, expand Language 
Elements. Then expand Statements, Keywords & 
Directives, and expand Definition Keyword. 


16. Double-click the function keyword in the Actions 
toolbox. 


 The code for creating a function appears in the Script 
pane. 


17. In the parameters area of the Script pane, type the name 
of your function in the Name field. 


 Note: You must type the function name exactly as you 
typed it for the AddEventListener function. Function 
names are case-sensitive. 


18. In the parameters area of the Script pane, type 
event:MouseEvent in the Parameters field (Figure 11). 


 In this field, you are naming a variable (event) and 
indicating what type of variable it is (MouseEvent). 


19. In the Actions toolbox on the left side of the panel, 
select the StopAll method for the SoundMixer class. 


 To find the StopAll method, expand Flash.Media, and 
then expand SoundMixer. 


 
Figure 9 CLICK property in the Actions toolbox 


 


 
Figure 10 CLICK property in the Script pane 


 


 
Figure 11 Function code in the Script pane 
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20. Select the function in the Script pane and double-click 
the StopAll method in the Actions toolbox. 


 The method is added to the function (Figure 12). 


21. Save the movie. 


 Now when visitors click the button, all sounds currently 
playing in the movie will stop. 


  
Figure 12 StopAll method in the Actions panel 


For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, 
select Help > Flash Help). 
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How to use a motion guide with a motion tween 
animation 
In Adobe Flash CS4, motion guides appear when you create motion tweens. By using a motion guide, you can move 
an object along an editable path.  


1. Select the layer that contains the object you wish to 
animate. 


2. Select Insert > Motion Tween. 


 Notice the tween in the Timeline layer (Figure 1) 


3. On the Stage, move the object and notice the motion 
guide appear (Figure 2). 


4. Click and drag a point on the motion guide. Edit as 
many points of the guide as necessary (Figure 3). 


5.  Turn Onion Skinning on to see how the object moves 
(Figure 4). 


6. Select Control > Test Movie to see it play. 


 Observe that the object moves along the guide. 


7. Select File > Close to close the preview window. 


 
Figure 1 Object layer with motion tween applied 


 


 
Figure 2 Motion guide 


 


 
Figure 3 Editing the motion guide 


 


 
Figure 4 Object moving along the guide 


 









